[SOLVED] Can't delete a snapshot

Hi all,

Any idea where I can look for in order to delete my snapshots ?
This virtual machine has 3, and the 2 first ones can’t be deleted.

oneadmin@vlab:~> onevm snapshot-delete 295 1
Thu May 23 05:10:10 2019 [Z0][VM][I]: New LCM state is HOTPLUG_SNAPSHOT
oneadmin@vlab:~> Thu May 23 05:10:10 2019 [Z0][VMM][I]: Command execution failed (exit code: 1): ‘if [ -x “/var/tmp/one/vmm/kvm/snapshot_delete” ]; then /var/tmp/one/vmm/kvm/snapshot_delete one-295 snap-1 295 s12kvm; else exit 42; fi’
Thu May 23 05:10:10 2019 [Z0][VMM][E]: snapshot_delete: Command “virsh --connect qemu:///system snapshot-delete one-295 snap-1” failed: error: Domain snapshot not found: no domain snapshot with matching name ‘snap-1’
Thu May 23 05:10:10 2019 [Z0][VMM][I]: error: Domain snapshot not found: no domain snapshot with matching name ‘snap-1’
Thu May 23 05:10:10 2019 [Z0][VMM][E]: Could not delete snapshot snap-1 for domain one-295.
Thu May 23 05:10:10 2019 [Z0][VMM][E]: Error deleting VM Snapshot: Could not delete snapshot snap-1 for domain one-295.
Thu May 23 05:10:10 2019 [Z0][VM][I]: New LCM state is RUNNING

onevm show 295 shows
(…)
SNAPSHOTS
ID TIME NAME HYPERVISOR_ID
1 05/03 17:51 2019.05.03 - Workingl image snap-1
2 05/21 13:20 2019.05.21 - Base pwds snap-2
4 05/23 05:07 DEFAULT snap-4
(…)

Anyone has a hint by any chance ?

Hello @saint

What is your TM_MAD ? And can you check if ALLOW_ORPHANS is enabled in the oned.conf for your TM_MAD ?

Regards

I fixed the issue by deleting the ghost info in the database.