Default cache settings for qcow2 images

(Edouard (Madko)) #1

Please, describe the problem here and provide additional information below (if applicable) …

We’d like to configure cache to none for image in qcow2 format. It was working fine before 5.4.

Versions of the related components and OS (frontend, hypervisors, VMs):

OpenNebula 5.4 on CentOS 7 using KVM

Steps to reproduce:

I’m configuring this in /etc/one/vmm_exec/vmm_exec_kvm.conf

DISK = [ driver = “qcow2” , cache = “none”]

then I restart opennebula services and deploy a VM using a qcow2 image

Current results:

virsh dumpxml VM shows no cache settings.

Expected results:

virsh dumpxml VM should show cache settings according to /etc/one/vmm_exec/vmm_exec_kvm.conf. Here it should be cache=none in the libvirt VM XML definition.

(Anton Todorov) #2


When deploying a VM before vmm_exec_kvm.conf two more places are checked for existence of the values:

First is the storage section of the VM template (Templates -> VM template -> Storage -> (select disk) -> Advanced options). If there is no variable defined the IMAGE template is checked (Storage -> Images -> (select image) -> Attributes).

I’d check the above places and there is nothing fishy I’d check the quotes used. At least in your post they are unicode opening and closing quotes that might be not recognized properly by oned.

If everything of the above is correct it is probably a bug somewhere.

Anton Todorov

(Edouard (Madko)) #3

Thank you Anton I think I haven’t restarted the right service + as you said, it was force inside the VM template.