vOneCloud Active Directory Integration


#1

Please, describe the problem here and provide additional information below (if applicable) …

I have downloaded the vOneCloud 3.2.1 appliance and deployed it successfully. I’m currently trying to configure AD integration. I have followed the instructions in the documentation but there is no example on the correct syntax to use.

Can someone please post a real example on what is expected in the fields to make this work, please?

The configuration I’m using

Server Name: server.domain.com
User: username
Password: **********
Athentication Method: simple
Encryption: LEFT BLANK
Host: server.domain.com
Port: 389
Base Domain: dc=domain,dc=com
Group: cn=OpenNebulaAdmins,ou=Security,dc=domain,dc=com
User Field: sAMAccountName
Group Field: member
User Group Field: user_group_field

.

I think I just need to see an example…


#2

Here are some of the log errors:

Tue Jan 8 20:20:54 2019 [Z0][AuM][E]: Auth Error:
Tue Jan 8 20:20:54 2019 [Z0][ReM][D]: Req:8864 UID:-1 one.user.info invoked , -1
Tue Jan 8 20:20:54 2019 [Z0][ReM][E]: Req:8864 UID:- one.user.info result FAILURE [one.user.info] User couldn’t be authenticated, aborting call.
Tue Jan 8 20:20:55 2019 [Z0][AuM][D]: Message received: LOG I 4 Command execution failed (exit code: 255): /var/lib/one/remotes/auth/ldap/authenticate

Tue Jan 8 20:20:54 2019 [Z0][AuM][I]: Trying LDAP server domain.com
Tue Jan 8 20:20:54 2019 [Z0][AuM][D]: Message received: LOG I 3 User usernam@domain.com not found


(Andree) #3

i would try changing the username to UPN.

:user: 'user@domain.tld'

ldap

	# Ldap user able to query, if not set connects as anonymous. For
    # Active Directory append the domain name. Example:
    # Administrator@my.domain.com
    #:user: 'admin'
    #:password: 'password'

and leave encryption commented, not blank.
#:encryption: :simple_tls

here is an example you can try out