Vm will not boot


#1

Please, describe the problem here and provide additional information below (if applicable) …

New to Open Nebula here. Using the virtualbox sandbox and attempted to build a centos vm. I have an iso and blank disk attached and have instantiated the vm. No matter what I do it just sits at the pxe boot and doesn’t seem to even attempt any other boot methods. Any help is appreciated. Open Nebula looks great!

Versions of the related components and OS (frontend, hypervisors, VMs):

Steps to reproduce:

Current results:

Expected results:


#2

Dear @dmatthewsbnd251,

Are you creating a new template? You mentioned Virtualbox… So I dunno what you’re trying to do…
If the following doesn’t help, please expand on what you’re trying to do.

If you are creating a new template, you will need 2 disks:

  • Disk 1: the VM disk;
  • Disk 2: the OS media (CD/DVD).

I will assume you have already setup OpenNebula, with correct Infrastructure/Hosts and Storage/Datastores

Go to Storage/Images, and add the following 2 new images:

  • OS Media (upload the ISO you got)
    • Type: Readonly CD-ROM
    • Advanced Options:
      • Bus: SCSI
      • Image mapping driver: raw
  • VM Disk
    • Type: Generic storage datablock
    • Empty disk image, and choose a starting size (20GB / 2048MB if you like)
    • Advanced Options:
      • Bus: virtio
      • Image mapping driver: raw

Now, you need to create a template (Templates/VMs):

  • Create a new template with all the options you want;
  • Add 2 disks to the template and choose the images you created previously;
  • Don’t forget: in advanced options, choose EXACTLY like previously (SCSI/virtio…).

Instantiate the template, it should work!


#3

Thanks for the help. There were a couple of other things that I needed to do in order for this to work on VirtualBox. The first is that on Virtualbox the processor extensions are not passed through and you have to force it to qemu from kvm.

/etc/one/oned.conf

From this:

VM_MAD = [
NAME = “kvm”,
SUNSTONE_NAME = “KVM”,
EXECUTABLE = “one_vmm_exec”,
ARGUMENTS = “-t 15 -r 0 kvm”,
DEFAULT = “vmm_exec/vmm_exec_kvm.conf”,
TYPE = “kvm”,
KEEP_SNAPSHOTS = “no”,
IMPORTED_VMS_ACTIONS = “terminate, terminate-hard, hold, release, suspend,
resume, delete, reboot, reboot-hard, resched, unresched, disk-attach,
disk-detach, nic-attach, nic-detach, snap-create, snap-delete”
]

To this

VM_MAD = [
NAME = “kvm”,
SUNSTONE_NAME = “KVM”,
EXECUTABLE = “one_vmm_exec”,
ARGUMENTS = “-t 15 -r 0 kvm”,
DEFAULT = “vmm_exec/vmm_exec_kvm.conf”,
TYPE = “qemu”,
KEEP_SNAPSHOTS = “no”,
IMPORTED_VMS_ACTIONS = “terminate, terminate-hard, hold, release, suspend,
resume, delete, reboot, reboot-hard, resched, unresched, disk-attach,
disk-detach, nic-attach, nic-detach, snap-create, snap-delete”
]

Notice that type was changed. Restart open nebula from there.

The second thing is that it it would not boot the cdrom on the SCSI bus but would with the IDE one.

Now I do have a second problem. I’m not exactly a network engineer. I basically just want to be able to have the vm sit on the same network as my home LAN. I can’t even get any sort of network to work at all though. I have followed this guide to set up a bridge:

https://wiki.centos.org/Cloud/OpenNebula/QuickStart

Using the interface I have created a network with these options:

bridge = br0
address start: 10.175.100.60 (my home network is on 10.175.100.0/24)
size: 20

When I boot the CentOS installation cd (using a network install iso), and I attempt to enable the network either by not configuring the network (should be picked up by the dhcp server), or manually configuring the address, it does not work. The funny thing is that it even wants to default to a 100Mps card.

Anyway, I’m getting no connectivity at all. Any help or advice here would be really appreciated.


#4

Does your template contain the network in the context? i.e: CONTEXT = [ USERNAME = root, PASSWORD = password, NETWORK = YES ] This is kind of mentioned at https://docs.opennebula.org/5.4/operation/network_management/manage_vnets.html

Trying to follow instructions that involve GUIs and find out what went wrong is a lost cause. This is why I’m maintaining this tutorial https://github.com/marcindulak/vagrant-opennebula-tutorial-centos7 - you need to become familiar with Vagrant, but that is a well invested time.


#5

I got it to work and because I made a few changes simultaneously can’t say for sure what did it.

  1. Disabled firewalld on the host
  2. Enabled STP on the bridge interface
  3. Set the hardware type to virtio. The default seems to be a 100Mbps Realtech interface.

Now when I enable the interface during the installation it does in fact get an ip address from my router like I had hoped.

Thanks for the link and for taking the time with some newbie-ish questions. I will likely reference it down the line.


(dagu92) #6

hi, i have a problem after i created the 2 images, one for disk and one for iso image for windows. the boot starts with the windows installation (in the vnc) but it does not recognize no disk where to install windows…anyone can help me? thanks


(Anton Zubkov) #7

Hello,
You need virtio drivers disk.


(dagu92) #8

ok, where and how can i download and set up these drivers?


(Anton Zubkov) #9