[solved] Stale VNets and other resources in VDCs, ACLs

solved
(Jan "Yenya" Kasprzak) #1

Hello,

my ONe install exists for a long time now, having been continuously upgraded since the 4.x times. Today I have discovered that there are references to the VNets and other resources which were deleted many months ago. For example:

# onevdc show 103
VDC 103 INFORMATION                                                             
ID                : 103                 
NAME              : myvdc        

 GROUPS
    103

CLUSTERS                                                                        
   ZONE   CLUSTER
      0       101

HOSTS                                                                           
   ZONE      HOST
      0       ALL

DATASTORES                                                                      
   ZONE DATASTORE
      0         0
      0         2
      0       100
      0       110
      0       111
      0       112

VNETS                                                                           
   ZONE      VNET
      0         5
      0         7
      0        21

From the above VNets, only the VNet ID=7 still exists, and from the above datastores, only IDs 0, 2, and 100 stil exist. I tried to stop oned and run onedb fsck, but apparently it cannot detect and fix this type of inconsitencies. I am even not able to remove the stale resources from this VDC via Sunstone.

I also have a similar problem in ACLs - some of them are apparently referencing non-existing objects.

How can I fix this? Thanks,

-Yenya

(Alejandro Huertas) #2

Hello @Yenya

You can use onedb update-body vdc --id 103 and delete from there everything you need.

(Jan "Yenya" Kasprzak) #3

OK, thanks. A few moments ago I managed to get rid of the stale resources by checking the [x]All checkbox for VNets and Datastores, storing the state with the [Update] button, and then unchecking it once again.