[SOLVED] Can opennebula-frontend-5.8 and opennebula-node-host-4.14 versions be used together?

solved
(Just So So) #1

For some reasons, the KVM host (centos6.5) cannot be upgraded to centos7.

Centos6 on the official website only supports OpenNebula version 4.14 at the highest level.

I want to deploy opennebula-5.8 with CentOS 7 to manage the KVM host of CentOS 6.5. Is that all right?

When I tried to do this, I added the wrong message when adding the host as follows:
Tue Apr 2 12:11:18 2019 [Z0][ONE][E]: Error monitoring Host host3 (16): ./pci.rb:33: uninitialized constant NAME (NameError)
ERROR MESSAGE --8<------
Error executing pci.rb
ERROR MESSAGE ------>8–
ARCH=x86_64
MODELNAME=“Intel® Xeon® CPU E3-1220 v5 @ 3.00GHz”
HYPERVISOR=kvm
TOTALCPU=400
CPUSPEED=3000
TOTALMEMORY=3924416
USEDMEMORY=203356
FREEMEMORY=3721060
FREECPU=400
USEDCPU=0
NETRX=106478431
NETTX=2733633
DS_LOCATION_USED_MB=914
DS_LOCATION_TOTAL_MB=9843
DS_LOCATION_FREE_MB=8429
DS = [
ID = 0,
USED_MB = 914,
TOTAL_MB = 9843,
FREE_MB = 8429
]
HOSTNAME=host3

Haha, my English is not good, the translation from Google.

0 Likes

(Alejandro Huertas) #2

Hi @you-can-change

In OpenNebula 5.8 only CentOS 7 is supported, so maybe there is a compatibility error with CentOS 6, here you can see all the supported platforms.

0 Likes

(Just So So) #3

Thanks !!!

0 Likes