[SOLVED] [5.8.0] Unable to list VMs in sunstone

solved

(telecast) #1

Hi,

after upgrade from opennebula v 5.4.13 the VMs list under view: admin and user (Mixed mode) in sunstone is empty.

log:

action.js:205 TypeError: graphics.TYPE.toLowerCase is not a function
at Object.isVNCSupported (vm.js:841)
at Object._elementArray [as elementArray] (datatable-common.js:52)
at Table._elementArray [as elementArray] (datatable.js:122)
at Object. (tab-datatable.js:607)
at Function.each (jquery.js:365)
at Table._updateView [as updateView] (tab-datatable.js:606)
at callback (common-actions.js:46)
at Object.success (action.js:203)
at fire (jquery.js:3187)
at Object.fireWith [as resolveWith] (jquery.js:3317)
success @ action.js:205
fire @ jquery.js:3187
fireWith @ jquery.js:3317
done @ jquery.js:8785
(anonymous) @ jquery.js:9151
load (async)
send @ jquery.js:9170
ajax @ jquery.js:8684
list @ action.js:173
list @ vm.js:365
_runAction @ sunstone.js:896
onShow @ dashboard-tab.js:76
(anonymous) @ dashboard-tab.js:237
each @ jquery.js:365
_onShow @ dashboard-tab.js:235
_runAction @ sunstone.js:937
_routerShowTab @ sunstone.js:694
(anonymous) @ sunstone.js:1255
resolve @ tips.js:41
_setupNavigoRoutes @ sunstone.js:1265
(anonymous) @ app.js:50
fire @ jquery.js:3187
add @ jquery.js:3246
jQuery.fn.ready @ jquery.js:3496
(anonymous) @ app.js:41
main @ almond.js:314
callDep @ almond.js:180
main @ almond.js:305
(anonymous) @ almond.js:388
setTimeout (async)
req @ almond.js:387
(anonymous) @ main.js:356

This issue seems to have been previously reported

I checked clean install opennebula 5.8.0 VM’s list in susntone fine worked (show running VM).
But after migrated DB (mysql) from opennebula 5.4 sunstone not show VM’s list.
In CLI onevm list work fine.

CentOS 7_64
$ rpm -qa | grep mariadb
mariadb-libs-5.5.60-1.el7_5.x86_64
mariadb-server-5.5.60-1.el7_5.x86_64
mariadb-5.5.60-1.el7_5.x86_64

# rpm -qa | grep opennebula
opennebula-sunstone-5.8.0-1.noarch
opennebula-server-5.8.0-1.x86_64
opennebula-common-5.8.0-1.noarch
opennebula-flow-5.8.0-1.noarch
opennebula-ruby-5.8.0-1.noarch
opennebula-gate-5.8.0-1.noarch
opennebula-5.8.0-1.x86_64
mariadb-devel-5.5.60-1.el7_5.x86_6

# ruby -v
ruby 2.0.0p648 (2015-12-16) [x86_64-linux]

Have any idea why?


(Alejandro Huertas) #2

Hello @telecast

Could you please send me the current database you are using?


(telecast) #3

Hi @ahuertas
is there any other way to debug that issue with DB?


(Alejandro Huertas) #4

I will try to, I don’t know why might be causing the error, in my current installation it works.


(Alejandro Huertas) #5

Hi @telecast

Please take a look at this, maybe it helps you: http://docs.opennebula.org/5.8/intro_release_notes/release_notes/known_issues.html#upgrade-process


(telecast) #6

Hi @ahuertas

Thank you for your help! This file really helped for me to solve the problem. Now Sunstone show VM list. Perhaps someone will help solve a similar problem.