Problems with Wilds

When I try to Import the Wilds, nothing happens…
When I press the Import Wilds button, nothing at all happens.

Thanks for help.

Could you share your /var/log/one/oned.log file on that time interval?

Mon Sep 23 07:26:00 2019 [Z0][ReM][D]: Req:3280 UID:0 IP:127.0.0.1 one.host.info invoked , 0
Mon Sep 23 07:26:00 2019 [Z0][ReM][D]: Req:3280 UID:0 one.host.info result SUCCESS, “0<NAM…”
Mon Sep 23 07:26:00 2019 [Z0][ReM][D]: Req:4544 UID:0 IP:127.0.0.1 one.system.config invoked
Mon Sep 23 07:26:00 2019 [Z0][ReM][D]: Req:4544 UID:0 one.system.config result SUCCESS, “<API_LIST_…”

Nobody has an idea?

The problem is remaining…

Hello @RimRex

Does the import work using CLI?

How can I do the Import over the CLI?

KVM

$ onehost importvm --help
## USAGE
importvm <hostid> <name>
        Import VM to OpenNebula

## OPTIONS
     -h, --help                Show this message
     -V, --version             Show version and copyright information
     --user name               User name used to connect to OpenNebula
     --password password       Password to authenticate with OpenNebula
     --endpoint endpoint       URL of OpenNebula xmlrpc frontend

vCenter

$ onevcenter import --help
## USAGE
import [<oid>]
        Import the the desired vCenter object
        
        Examples:
           - importing first datastore
        
             onevcenter list -o templates -h <host_id>
        
           - importing 2 concrete templates:
        
             onevcenter import "vm-1252, vm-553, vm-1248" -o templates -h <host_id>
        
           - importing a image range:
        
             onevcenter import 0..10 -o images -h <host_id> -d <ds-img_id>
        valid options: object, host, datastore

## OPTIONS
     -o, --object object       vCenter object: [datastores, templates,networks,
                               datastores, images]
     -h, --host host_id        OpenNebula host used to authenticate the
                               operation
     -d, --datastore datastore_id OpenNebula datastore used
     -h, --help                Show this message
     -V, --version             Show version and copyright information
     --user name               User name used to connect to OpenNebula
     --password password       Password to authenticate with OpenNebula
     --endpoint endpoint       URL of OpenNebula xmlrpc frontend

I don’t have the onecenter bash…

When I try to import with onehost, it is shown that no host is named like DMIC_SIA-DMI_FS01.
image

Looks like you are missing the " - Cluster 1" suffix

Any Ideas?

When passing arguments with spaces to a process in the command line, you must use single (or double, if var substitution is needed) quotes.

Tahnk you it is working :slight_smile:
onehost importvm HOST “VM NAME”

But by 3 VMs I’ve got following error:

Try upgrading to 5.8.5 if you are on an older version

Importing wild VMs not working on 5.8.5. It’s not working since 5.8.1. I was an opened issue on GitHub but nothing resolved and the issue closed.

Hi Anton,

Are you referring to this issue? https://github.com/OpenNebula/one/issues/3533

We need more feedback to reproduce and reopen the ticket.