Problem with Ceph Mimic


#1

We are currently trying to deploy a new virtual machine which fails:

Thu Jul 12 11:07:53 2018 [Z0][TM][D]: Message received: LOG I 522 Command execution fail: /var/lib/one/remotes/tm/ceph/clone sun02.23media.de:SAFE_DIRS virt02:/var/lib/one//datastores/103/522/disk.0 522 104
Thu Jul 12 11:07:53 2018 [Z0][TM][D]: Message received: LOG E 522 clone: Command "    RBD="rbd --id libvirt"
Thu Jul 12 11:07:53 2018 [Z0][TM][D]: Message received: LOG I 522
Thu Jul 12 11:07:53 2018 [Z0][TM][D]: Message received: LOG I 522 rbd --id libvirt info SAFE_DIRS-522-0 >/dev/null 2>&1 && exit 0
Thu Jul 12 11:07:53 2018 [Z0][TM][D]: Message received: LOG I 522
Thu Jul 12 11:07:53 2018 [Z0][TM][D]: Message received: LOG I 522 rbd_make_snap SAFE_DIRS
Thu Jul 12 11:07:53 2018 [Z0][TM][D]: Message received: LOG I 522
Thu Jul 12 11:07:53 2018 [Z0][TM][D]: Message received: LOG I 522 set -e -o pipefail
Thu Jul 12 11:07:53 2018 [Z0][TM][D]: Message received: LOG I 522
Thu Jul 12 11:07:53 2018 [Z0][TM][D]: Message received: LOG I 522 if [ "$(rbd_format SAFE_DIRS)" = "2" ]; then
Thu Jul 12 11:07:53 2018 [Z0][TM][D]: Message received: LOG I 522 rbd --id libvirt clone "SAFE_DIRS@snap" SAFE_DIRS-522-0
Thu Jul 12 11:07:53 2018 [Z0][TM][D]: Message received: LOG I 522 else
Thu Jul 12 11:07:53 2018 [Z0][TM][D]: Message received: LOG I 522 rbd --id libvirt copy SAFE_DIRS SAFE_DIRS-522-0
Thu Jul 12 11:07:53 2018 [Z0][TM][D]: Message received: LOG I 522 fi
Thu Jul 12 11:07:53 2018 [Z0][TM][D]: Message received: LOG I 522
Thu Jul 12 11:07:53 2018 [Z0][TM][D]: Message received: LOG I 522 if [ -n "20480" -a "174080" -gt "20480" ]; then
Thu Jul 12 11:07:53 2018 [Z0][TM][D]: Message received: LOG I 522 rbd --id libvirt resize SAFE_DIRS-522-0 --size 174080
Thu Jul 12 11:07:53 2018 [Z0][TM][D]: Message received: LOG I 522 fi" failed: rbd: error opening default pool 'rbd'
Thu Jul 12 11:07:53 2018 [Z0][TM][D]: Message received: LOG I 522 Ensure that the default pool has been created or specify an alternate pool name.
Thu Jul 12 11:07:53 2018 [Z0][TM][D]: Message received: LOG I 522 rbd: error opening default pool 'rbd'
Thu Jul 12 11:07:53 2018 [Z0][TM][D]: Message received: LOG I 522 Ensure that the default pool has been created or specify an alternate pool name.
Thu Jul 12 11:07:53 2018 [Z0][TM][D]: Message received: LOG I 522 rbd: error opening default pool 'rbd'
Thu Jul 12 11:07:53 2018 [Z0][TM][D]: Message received: LOG I 522 Ensure that the default pool has been created or specify an alternate pool name.
Thu Jul 12 11:07:53 2018 [Z0][TM][D]: Message received: LOG E 522 Error cloning SAFE_DIRS to SAFE_DIRS-522-0 in virt02
Thu Jul 12 11:07:53 2018 [Z0][TM][D]: Message received: LOG I 522 ExitCode: 2
Thu Jul 12 11:07:53 2018 [Z0][TM][D]: Message received: TRANSFER FAILURE 522 Error cloning SAFE_DIRS to SAFE_DIRS-522-0 in virt02

We have recently upgraded to cepg mimic. I do not know if there has been some syntax changes which may affect this?

We are using one-5.4.11 - but I do not see anything regarding this error in the later hotfixes.