Powered off virtualmachine still working


(Paolo) #1

Hi all
I have experienced a strange behavior of my virtual machines.
If I poweroff them and then I click on VNC I get a fully working virtual machine.

Thu Dec 17 17:38:48 2015 [Z0][VM][I]: New state is ACTIVE
Thu Dec 17 17:38:48 2015 [Z0][VM][I]: New LCM state is BOOT_POWEROFF
Thu Dec 17 17:38:48 2015 [Z0][VMM][I]: Generating deployment file: /var/lib/one/vms/22/deployment.6
Thu Dec 17 17:38:49 2015 [Z0][VMM][I]: ExitCode: 0
Thu Dec 17 17:38:49 2015 [Z0][VMM][I]: Successfully execute network driver operation: pre.
Thu Dec 17 17:38:53 2015 [Z0][VMM][I]: ExitCode: 0
Thu Dec 17 17:38:53 2015 [Z0][VMM][I]: Successfully execute virtualization driver operation: deploy.
Thu Dec 17 17:38:53 2015 [Z0][VMM][I]: ExitCode: 0
Thu Dec 17 17:38:53 2015 [Z0][VMM][I]: Successfully execute network driver operation: post.
Thu Dec 17 17:38:53 2015 [Z0][VM][I]: New LCM state is RUNNING
Thu Dec 17 17:39:23 2015 [Z0][VM][I]: New LCM state is SHUTDOWN_POWEROFF
Thu Dec 17 17:44:31 2015 [Z0][VMM][I]: Command execution fail: /var/tmp/one/vmm/kvm/shutdown 'one-22' 'Crea' 22 Crea
Thu Dec 17 17:44:31 2015 [Z0][VMM][E]: Timed out shutting down one-22
Thu Dec 17 17:44:31 2015 [Z0][VMM][I]: ExitCode: 255
Thu Dec 17 17:44:31 2015 [Z0][VMM][I]: Failed to execute virtualization driver operation: shutdown.
Thu Dec 17 17:44:31 2015 [Z0][VMM][E]: Error shutting down VM: Timed out shutting down one-22
Thu Dec 17 17:44:31 2015 [Z0][VM][I]: New LCM state is RUNNING
Thu Dec 17 17:44:32 2015 [Z0][LCM][I]: Fail to shutdown VM. Assuming that the VM is still RUNNING (will poll VM).

Thank you


(Ruben S. Montero) #2

Hi

Probably you are issuing a shutdown for a VM without ACPI support. You may
try to enable it or issue a shutdown hard, note this is not an ordered
shutdown.

Cheers


(Dmitry Korzhevin) #3

Hello,

Seems, like this problem still exist in latest stable version - 5.6.2