Latest Opennebula 5.6installation, bundler gem is not compatible with Centos 7 Ruby breaks the sequence

Hello,

I was installing Opennebula 5.6 on an additional Centos7 node to expand my cloud and suddenly
when I executed the step to install gems I am getting an error

[root@localhost ~]# /usr/share/one/install_gems
Fetching: bundler-2.0.1.gem (100%)
ERROR:  Error installing bundler:
        bundler requires Ruby version >= 2.3.0.
/usr/share/one/install_gems:413:in `install_bundler_gem': undefined method `new' for #<IO:<STDERR>> (NoMethodError)
        from /usr/share/one/install_gems:592:in `<main>'

I was stuck - Centos7 latest Ruby is 2.0.0

[root@localhost ~]# rpm -q ruby
ruby-2.0.0.648-35.el7_6.x86_64

However have 3 other Centos7 nodes running Opennebula, same rpm version but I didn’t have such error before.
This allowed me to work around the problem, by forcing same bundler gem version as I have on other nodes,
after running

gem install bundler -v 1.16.4

I could continue with /usr/share/one/install_gems
So, to avoid this problem in the future /usr/share/one/install_gems should have bundler version forced to 1.16.4

Hi, there is already closed issue related to your problem.

Check you install_gems script a probably reopen issue

Sorry, didn’t check on github, only on forum.
Having quick workaround for the problem here would definitely help somebody to avoid this and similar problems in the future.