Idea: contextualization packages in package repo?


(Remy Zandwijk) #1

Hi,

at the moment, one needs to download and install the contextualisation package on a vm by hand. The same is true when an updated package is available.

Wouldn’t it be easier to have the contextualization packages available in the OpenNebula package repositories as well? That way, the package is automatically updated when for example apt-get upgrade is run.

Best regards,
Remy


(Strahinja Kustudić) #2

I would strongly be against that because we change some one-context scripts in our VM images and also delete some of them after the first VM boot. If one-context was part of the OpenNebula repository, that would mean by updating the packages, it would restore/update all the changed scripts, which is not what you want.


(Remy Zandwijk) #3

Making the one-context package available in the package repo does not imply that you need to install the one-context package, right? You can choose wether or not you install it. If you install it, you would benefit from automatic updates, if not, you can keep using your current workflow.