I need fast help error on creating vm


(Swe Gamer Here Gamer) #1

When i just create a vm

i need to deploy i think i deploy with name node01 and this failure and in vm log is just printed:

Sun Dec 17 13:49:33 2017 [Z0][VM][I]: New state is ACTIVE
Sun Dec 17 13:49:33 2017 [Z0][VM][I]: New LCM state is PROLOG
Sun Dec 17 13:49:34 2017 [Z0][TM][I]: Command execution fail: /var/lib/one/remotes/tm/ssh/clone Public-Server:/var/lib/one//datastores/1/13b47bbe0a4905f0a1ff6f9c36dc9a63 node01:/var/lib/one//datastores/0/3/disk.0 3 1
Sun Dec 17 13:49:34 2017 [Z0][TM][E]: Error creating directory /var/lib/one/datastores/0/3 at node01: ssh: Could not resolve hostname node01: Name or service not known
Sun Dec 17 13:49:34 2017 [Z0][TM][I]: ExitCode: 255
Sun Dec 17 13:49:34 2017 [Z0][TM][E]: Error executing image transfer script: Error creating directory /var/lib/one/datastores/0/3 at node01: ssh: Could not resolve hostname node01: Name or service not known
Sun Dec 17 13:49:34 2017 [Z0][VM][I]: New LCM state is PROLOG_FAILURE

please help what i have do fail?

Thanks before!

Sorry my bad english

network is configured like this:

template:

BRIDGE = "onebr1"
DESCRIPTION = "A private network for VM inter-communication"
DNS = "10.0.0.23"
GATEWAY = "10.0.0.1"
PHYDEV = "eth0"
SECURITY_GROUPS = "0"
VN_MAD = “802.1Q”

and in hosts the node01 host is this a error? Allocated Memory 128MB / - Allocated CPU 10 / 0
Real Memory 0KB / -

Real CPU 0 / 0

Information
ID 3
Name node01
Cluster default
State MONITORING_ERROR
IM MAD kvm
VM MAD kvm

Attributes
ERROR Sun Dec 17 13:52:54 2017 : Error monitoring Host node01 (3): -
IM_MAD kvm
VM_MAD kvm

Overcommitment Update
CPU
0

0
Memory
0KB

0KB

another things under vm machine

vm template:

ERROR = "Sun Dec 17 13:49:34 2017 : Error executing image transfer script: Error creating directory /var/lib/one/datastores/0/3 at node01: ssh: Could not resolve hostname node01: Name or service not known"
LOGO = "images/logos/linux.png"
SCHED_MESSAGE = "Sun Dec 17 13:49:25 2017 : Cannot dispatch VM to any Host. Possible reasons: Not enough capacity in Host or System DS, or dispatch limit reached"
Template
AUTOMATIC_DS_REQUIREMENTS = "“CLUSTERS/ID” @> 0"
AUTOMATIC_REQUIREMENTS = "(CLUSTER_ID = 0) & !(PUBLIC_CLOUD = YES)"
CONTEXT = [
DISK_ID = “1”,
ETH0_CONTEXT_FORCE_IPV4 = “”,
ETH0_DNS = “10.0.0.23”,
ETH0_GATEWAY = “10.0.0.1”,
ETH0_GATEWAY6 = “”,
ETH0_IP = “10.0.0.150”,
ETH0_IP6 = “”,
ETH0_IP6_PREFIX_LENGTH = “”,
ETH0_IP6_ULA = “”,
ETH0_MAC = “02:00:0a:00:00:96”,
ETH0_MASK = “”,
ETH0_MTU = “”,
ETH0_NETWORK = “”,
ETH0_SEARCH_DOMAIN = “”,
ETH0_VLAN_ID = “”,
ETH0_VROUTER_IP = “”,
ETH0_VROUTER_IP6 = “”,
ETH0_VROUTER_MANAGEMENT = “”,
NETWORK = “YES”,
SSH_PUBLIC_KEY = “”,
TARGET = “hda” ]
CPU = "0.1"
DISK = [
ALLOW_ORPHANS = “NO”,
CLONE = “YES”,
CLONE_TARGET = “SYSTEM”,
CLUSTER_ID = “0”,
DATASTORE = “default”,
DATASTORE_ID = “1”,
DEV_PREFIX = “vd”,
DISK_ID = “0”,
DISK_SNAPSHOT_TOTAL_SIZE = “0”,
DISK_TYPE = “FILE”,
DRIVER = “qcow2”,
IMAGE = “ttylinux - kvm”,
IMAGE_ID = “0”,
IMAGE_STATE = “2”,
LN_TARGET = “SYSTEM”,
ORIGINAL_SIZE = “200”,
READONLY = “NO”,
SAVE = “NO”,
SIZE = “200”,
SOURCE = “/var/lib/one//datastores/1/13b47bbe0a4905f0a1ff6f9c36dc9a63”,
TARGET = “vda”,
TM_MAD = “ssh”,
TYPE = “FILE” ]
GRAPHICS = [
LISTEN = “0.0.0.0”,
PORT = “5903”,
TYPE = “vnc” ]
MEMORY = "128"
NIC = [
AR_ID = “0”,
BRIDGE = “onebr1”,
CLUSTER_ID = “0”,
IP = “10.0.0.150”,
MAC = “02:00:0a:00:00:96”,
NETWORK = “Private”,
NETWORK_ID = “1”,
NIC_ID = “0”,
PHYDEV = “eth0”,
SECURITY_GROUPS = “0”,
TARGET = “one-3-0”,
VN_MAD = “802.1Q” ]
SECURITY_GROUP_RULE = [
PROTOCOL = “ALL”,
RULE_TYPE = “OUTBOUND”,
SECURITY_GROUP_ID = “0”,
SECURITY_GROUP_NAME = “default” ]
SECURITY_GROUP_RULE = [
PROTOCOL = “ALL”,
RULE_TYPE = “INBOUND”,
SECURITY_GROUP_ID = “0”,
SECURITY_GROUP_NAME = “default” ]
TEMPLATE_ID = "0"
VMID = “3”

under templates and vm templates there after is templete
CONTEXT = [
NETWORK = “YES”,
SSH_PUBLIC_KEY = “$USER[SSH_PUBLIC_KEY]” ]
CPU = "0.1"
DISK = [
IMAGE_ID = “0” ]
GRAPHICS = [
LISTEN = “0.0.0.0”,
TYPE = “vnc” ]
LOGO = "images/logos/linux.png"
MEMORY = “128”

OS i just will install is ttylinux

another log under placements is Sched Message
Sun Dec 17 13:49:25 2017 : Cannot dispatch VM to any Host. Possible reasons: Not enough capacity in Host or System DS, or dispatch limit reached

Please help im so happy when i get help i didnt know what the problem is please help thanks so much!
Sorry for my bad english.


(Swe Gamer Here Gamer) #2

Ow i should say im running on esxi and i will create a kvm vm … System: ubuntu server 17.04


(Swe Gamer Here Gamer) #3

brctl show
bridge name bridge id STP enabled interfaces
virbr0 8000.525400fa72fd yes virbr0-nic


(Swe Gamer Here Gamer) #4

Please help Hello Someone?!?


(Kai 'wusel' Siering) #5

That’s your root cause it seems: the system the frontend runs on can’s ssh to oneadmin@node01, as node01 isn’t known. Put it properly into /etc/hosts and ensure the hosts file is used for name resolution (check /etc/nsswitch.conf).


(Михаил Знак) #6

i 'm newbie, and may be it’s stupid advice , but try change node1 to host ip. It’s work for me


(Swe Gamer Here Gamer) #7

Hi 1115 I have tested that but this take long time and vnc don,t work and cant reboot the machine or stop the machine but i can test it over the night, tomorrow or today i think and

wusel Can you give me a guide i can linux i good bit but i don,t know what you mean with name resolution check the nsswitch i don,t know what you mean Can you help? i run the server and vms on same machine i didnt run another machines for the frontend frontend is there my vms are i don,t have another computers that work together with the frontend thanks for help but please give me a constucted guide. Thanks again im very newbie too and how long time to setup machine take and more this is on prolog if i choose the machines ip on the host Im happy if i get it too work beaucse i work on to build a web hosting… Thanks…


(Edouard (Madko)) #8

It’s pretty simple, OpenNebula do not use Magic to manage VM. It uses SSH and the user “oneadmin” to manage VM. So if you can’t do ssh node01 from your opennebula host, you loose.

Try this first. Log in on your OpenNebula server as user oneadmin, and try the ssh node01
It will say ssh: Could not resolve hostname node01: Name or service not known

To fix that, add your hypervisor hostnames in your /etc/hosts on your OpenNebula server. This should be a line like:
IP_NODE01 node01

Or just read the documentation about OpenNebula installation. Because this is well explained.


(Swe Gamer Here Gamer) #9

I have tested but it don,t work i have tested this madko say and that 1115 say but i don,t get it to work i don,t now if i do that correct and wusel i don,t know how you mean can i get more constucted guide?


(Михаил Знак) #10

Did you use this document , when setuped your node?
http://docs.opennebula.org/5.4/deployment/node_installation/kvm_node_installation.html
It works anytime , when i do it


(Kai 'wusel' Siering) #11

If you’d have used @wusel, I might have read this earlier … In general it would help to provide proper sentences; I’m not an English native and some of your text doesn’t make sense to me.

That said, ssh: Could not resolve hostname node01: Name or service not known tells you what is the issue: there is no target host “node01” within your agreed-upon namespace.


(Swe Gamer Here Gamer) #12

Hi i can,t get it to work can someone build a tutorial and send here? or make a script just help me?


(Swe Gamer Here Gamer) #13

I will note i using esxi 6.5 can someone help me with a guide what i need to do if i need change settings in esxi on createing the opennebula machine? i have to install a new openenbula someone can guide and give me our own tutorial? how i should do? im would be so happy if i get it to work but someone can write a tutorial to me? and help me how to fix it? i need opennebula so much i being so have if i get some help to get it to work. !!!
:smiley:


(Swe Gamer Here Gamer) #14

I bad on english


(Swe Gamer Here Gamer) #15

@1115 @wusel @madko @codinghorror @roman to notice our to get this messages


(Edouard (Madko)) #16

Please stop the spam !

Read the doc :
http://docs.opennebula.org/5.4/deployment/node_installation/kvm_node_installation.html
and all the others