How to install OpenNebula 5.2.1 front-end and node in the same machine?

(Anderson Mattheus Maliszewski) #1

I follow the instructions of OpenNebula front-end installation and its working. I have only one machine for test OpenNebula. But i could not configure OpenNebula Node in the same machine. Can someone help me ?

(Miguel Ángel Alvarez Cabrerizo) #2

Hi Anderson!,
once you have the front-end installed you should follow the documentation about installing a KVM node in the same machine (if KVM is the hypervisor you want to use of course :wink:).

You can have front-end and node in the same machine for testing that’s perfectly fine, so can you tell us what Linux and version are you using, what errors have you found and what have you already tried?


(Miguel Ángel Alvarez Cabrerizo) #3

Hi Anderson!
don’t know if you finally got both front-end and node in the same machine. Another tip for you, as the oneadmin user try to open an SSH session against localhost: ssh oneadmin@ and ssh oneadmin@yourhostname and test if you can log in without password, you may have errors when trying to monitor the localhost node if SSH can’t be established without a password for the oneadmin user.


(Roman) #4

Hi @mcabrerizo!

I have the same problem. I want to install OpenNebula 5.4.1 frontend and node on the same machine.
I followed your advices and I can login from the oneadmin user to ssh oneadmin@ without password. I have added node to Sunstone host and it works, monitoring are working perfectly, I can see memory usage, disk usage, etc. but when I’m trying to add any VM, in log I see the next error:

Wed Oct 4 20:08:31 2017 [Z0][TM][E]: clone: Command "scp -r ubuntu-2gb-fra1-01:/var/lib/one//datastores/1/39f6eaf43b14ef931810198cff0686ed" failed: Host key verification failed.
Wed Oct 4 20:08:31 2017 [Z0][TM][E]: Error copying ubuntu-2gb-fra1-01:/var/lib/one//datastores/1/39f6eaf43b14ef931810198cff0686ed to
Wed Oct 4 20:08:31 2017 [Z0][TM][I]: ExitCode: 1

Could you help me with it?


(Anton Todorov) #5

Hi Roman,

Did you try ssh with oneadmin@ubuntu-2gb-fra1-01 too as suggested by @mcabrerizo?
The error command hints that it is trying to transfer the file from ubuntu-2gb-fra1-01:… to…

Best Regards,
Anton Todorov

(Roman) #6

Hi @atodorov_storpool,

ubuntu-2gb-fra1-01 it is hostname for this machine. I have tried to connect to as it’s also local IP.
Also, I have generated the known_hosts for and but it still did not work.
But, when I added node by the hostname (in my case it is ubuntu-2gb-fra1-01) it is started to work perfectly.

Thank you for you help.