How to create Windows VM?


(Roland) #21

hi oscar,

this might be worth a look, as can be seen in this bugreport, this message might be caused by differences between the CPU’s in your cluster. In the example posted there, the “monitor” flag is only present on the first core of a CPU.
EDIT: forgot to post the link: https://bugzilla.redhat.com/show_bug.cgi?id=873926

Can you check if you see something similar in the CPU model you use?
Check if you see any differences in the features of your cores by using:
“cat /proc/cpuinfo” on your virtualization servers.


(Oscar) #22

I attach the info you have requested:

[root@vdicnode02 opt]# cat /proc/cpuinfo
processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 42
model name : Intel® Core™ i7-2600K CPU @ 3.40GHz
stepping : 7
microcode : 0x29
cpu MHz : 3399.334
cache size : 8192 KB
physical id : 0
siblings : 2
core id : 0
cpu cores : 2
apicid : 0
initial apicid : 0
fpu : yes
fpu_exception : yes
cpuid level : 13
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts mmx fxsr sse sse2 ss ht syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts nopl xtopology tsc_reliable nonstop_tsc aperfmperf pni pclmulqdq vmx ssse3 cx16 pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx hypervisor lahf_lm ida arat epb pln pts dtherm tpr_shadow vnmi ept vpid tsc_adjust
bogomips : 6800.05
clflush size : 64
cache_alignment : 64
address sizes : 42 bits physical, 48 bits virtual
power management:

processor : 1
vendor_id : GenuineIntel
cpu family : 6
model : 42
model name : Intel® Core™ i7-2600K CPU @ 3.40GHz
stepping : 7
microcode : 0x29
cpu MHz : 3399.334
cache size : 8192 KB
physical id : 0
siblings : 2
core id : 1
cpu cores : 2
apicid : 1
initial apicid : 1
fpu : yes
fpu_exception : yes
cpuid level : 13
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts mmx fxsr sse sse2 ss ht syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts nopl xtopology tsc_reliable nonstop_tsc aperfmperf pni pclmulqdq vmx ssse3 cx16 pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx hypervisor lahf_lm ida arat epb pln pts dtherm tpr_shadow vnmi ept vpid tsc_adjust
bogomips : 6800.05
clflush size : 64
cache_alignment : 64
address sizes : 42 bits physical, 48 bits virtual
power management:


(Roland) #23

I added the link to the bugreport, i forgot that earlier. The cpuinfo you pasted shows 2 cores of one host, right ?

Do you have any servers in your cluster with different CPU’s, i.e. other generation, or intel or amd mixed ?
You can check the capabilities of your hosts with:
“virsh capabilities” and look for any differences between CPU functions.

With “virsh dumpxml (name of VM)” you can check for things like:
<feature policy='require' name='monitor'/> that might be there.

more info: https://bugzilla.redhat.com/show_bug.cgi?id=873926


(Roland) #24

https://docs.fedoraproject.org/en-US/Fedora/18/html/Virtualization_Administration_Guide/ch15s13s03.html and:
https://docs.fedoraproject.org/en-US/Fedora/18/html/Virtualization_Administration_Guide/ch15s13s04.html

here is some good documentation about cpu features you can expose to your VMs.
Either you are the unlucky owner of a CPU that shows different features per core, like the guy in the bugzilla-post, or you should remove “require monitor” from your XML’s, which can be set/unset with the docs above.


(Carlos Gonzalez Vila) #25

In my case, Windows 7 hang on boot was solved with the next contents as RAW data in the template:

<cpu mode='host-model'>
        <topology sockets='2' cores='8' threads='2'/>
        <model fallback='allow'/>
</cpu>

(Oscar) #26

Hi, in the end, I have fixed it by setting tbe cpu host model to “Sandy Bridge”.

Thanks a lot


#27

In my case, this setting helped:

RAW = [ DATA = "<cpu mode='host-passthrough'></cpu>", TYPE = kvm ]


Installing Windows Server 2016 on OpenNebula 5.6.1 (nested virtualization)
(Jose Miguel Casado Alvarez) #29

Same case here!
Thanks marcindulak!
Thanks everyone!


Installing Windows Server 2016 on OpenNebula 5.6.1 (nested virtualization)
(Nikolay Alexandrov) #31

Hi all,
I followed the instructions from VURoland in second post of this thread, but I keep seeing this:win
Am I missing something?
Any advice will be welcome!
OpenNebula5.6.1, Ceph-13 as a storage, WindowsServer2012.iso for the VM and the hdd for windows has DRIVER=qcow2.


(Jean-Philippe FOURES) #32

Hello

In the second post @VURoland attached virtio-win.iso as CDROM to the VM template.

Last week I also tried to created windows based on Windows Server 2016 (it should also work with 2012).
What I did is a VM template with:

  • Windows ISO (Windows server 2012) CDROM image with driver raw
  • Virtio-win.ios CDROM image driver raw
  • Empty DATABLOCK Image with enought size (20GB for example) driver raw

Please note that using qcow2 driver didn’t work for me. I had to use raw instead.

Hope this help

Regards


(Nikolay Alexandrov) #33

Hello @jpfoures and thanks for the reply!
I changed it with empty datablock(50GB) and driver raw instead, but I ended with the screen posted in the previous post.
:frowning_face:
VirtIO.iso is also atached as a second CDROM, but the windows installer doesn’t see it.


(Jean-Philippe FOURES) #34

Hello,

Did you attach the virtio-win.iso as CDROM ?

You need this during installation. When Windows server ask for a Disk, when it is not able to find it you can browse for a driver. You need to provide the path to the CDROM letter with Virtio drivers.
Once driver is installed you should see a disk of 50GB.


(Nikolay Alexandrov) #35

@jpfoures BIG THANKS :beer:
I reattached VirtIO.iso with bus=pata(ide),driver=raw and managed to get the drivers loaded!