Error while installing Ruby Runtime Environment


Hi Here.

I’m new to the forum.
I’m trying to install Opennebula on Ubuntu 14.04 (using VmWare Workstation. This is for an internship report).
When I try to install Ruby Runtime Environment, I encounter the following error:
Rake = “/ usr / bin / rake” gem install --no-ri --no-rdoc aws-sdk --version "= 1.66"
Building native extensions. This could take a while …
ERROR: Error installing aws-sdk:
ERROR: Failed to build gem native extension.

Current directory: /var/lib/gems/2.4.0/gems/nokogiri-1.8.0/ext/nokogiri

/usr/bin/ruby2.4 -r ./siteconf20170703-14885-1me2n3a.rb extconf.rb
Mkmf.rb can not find header files for ruby ​​at /usr/lib/ruby/include/ruby.h

Extconf failed, exit code 1

Gem files will remain installed in /var/lib/gems/2.4.0/gems/nokogiri-1.8.0 for inspection.
Results logged to /var/lib/gems/2.4.0/extensions/x86_64-linux/2.4.0/nokogiri-1.8.0/gem_make.out
Error executing rake = “/ usr / bin / rake” gem install --no-ri --no-rdoc aws-sdk --version “= 1.66”

Can someone unlock me please ??? Thanks in advance

(Vlastimil Holer) #2


I’m not sure where did you get Ruby 2.4 inside the Ubuntu 14.04, as the distribution is shipped with Ruby 1.9. Also, I’m not sure which OpenNebula version are you trying. Anyway, the missing header file is usually installed as a dependency of the meta package ruby-dev (for Ubuntu 14.04 it is ruby1.9.1-dev, please change the version appropriately).

But for the start, you should ensure you have a clean system with only the vendor supported packages (no custom interpreters), then follow with the current stable OpenNebula 5.2 front-end installation guide.

Best regards,
Vlastimil Holer