Error running fsck version 5.6.0

I can’t upgrade to 5.8 because I am getting this on 5.6:

[UNREPAIRED] History record for VM 47 seq # 12 is not closed (etime = 0)
[UNREPAIRED] History record for VM 48 seq # 12 is not closed (etime = 0)

invalid address
/usr/lib/ruby/2.3.0/ipaddr.rb:395:in set' /usr/lib/ruby/2.3.0/ipaddr.rb:472:ininitialize’
/usr/lib/one/ruby/onedb/fsck/network.rb:265:in new' /usr/lib/one/ruby/onedb/fsck/network.rb:265:inblock (3 levels) in check_network’
/usr/lib/one/ruby/onedb/fsck/network.rb:242:in each' /usr/lib/one/ruby/onedb/fsck/network.rb:242:inblock (2 levels) in check_network’
/usr/lib/one/ruby/onedb/fsck/network.rb:174:in each' /usr/lib/one/ruby/onedb/fsck/network.rb:174:inblock in check_network’
/usr/lib/ruby/vendor_ruby/sequel/dataset/actions.rb:141:in block in each' /usr/lib/ruby/vendor_ruby/sequel/adapters/mysql2.rb:162:inblock (2 levels) in fetch_rows’
/usr/lib/ruby/vendor_ruby/sequel/adapters/mysql2.rb:162:in each' /usr/lib/ruby/vendor_ruby/sequel/adapters/mysql2.rb:162:inblock in fetch_rows’
/usr/lib/ruby/vendor_ruby/sequel/adapters/mysql2.rb:93:in _execute' /usr/lib/ruby/vendor_ruby/sequel/adapters/shared/mysql_prepared_statements.rb:36:inblock in execute’
/usr/lib/ruby/vendor_ruby/sequel/database/connecting.rb:251:in block in synchronize' /usr/lib/ruby/vendor_ruby/sequel/connection_pool/threaded.rb:105:inhold’
/usr/lib/ruby/vendor_ruby/sequel/database/connecting.rb:251:in synchronize' /usr/lib/ruby/vendor_ruby/sequel/adapters/shared/mysql_prepared_statements.rb:36:inexecute’
/usr/lib/ruby/vendor_ruby/sequel/dataset/actions.rb:952:in execute' /usr/lib/ruby/vendor_ruby/sequel/adapters/mysql2.rb:197:inexecute’
/usr/lib/ruby/vendor_ruby/sequel/adapters/mysql2.rb:156:in fetch_rows' /usr/lib/ruby/vendor_ruby/sequel/dataset/actions.rb:141:ineach’
/usr/lib/one/ruby/onedb/fsck/network.rb:164:in check_network' /usr/lib/one/ruby/onedb/fsck.rb:454:infsck’
/usr/lib/one/ruby/onedb/onedb.rb:280:in fsck' /usr/bin/onedb:405:inblock (2 levels) in ’
/usr/lib/one/ruby/cli/command_parser.rb:457:in run' /usr/lib/one/ruby/cli/command_parser.rb:84:ininitialize’
/usr/bin/onedb:294:in new' /usr/bin/onedb:294:in

Error running fsck version 5.6.0.

Ubuntu 16.04 ON 5.6.1

Hello @superxor

Could you please replace your network.rb (/usr/lib/one/ruby/onedb/fsck/network.rb) by this and try again.

[UNREPAIRED] History record for VM 47 seq # 12 is not closed (etime = 0)
[UNREPAIRED] History record for VM 48 seq # 12 is not closed (etime = 0)

invalid address
/usr/lib/ruby/2.3.0/ipaddr.rb:395:in set' /usr/lib/ruby/2.3.0/ipaddr.rb:472:ininitialize’
/usr/lib/one/ruby/onedb/fsck/network.rb:202:in new' /usr/lib/one/ruby/onedb/fsck/network.rb:202:inget_lease’
/usr/lib/one/ruby/onedb/fsck/network.rb:467:in block in calculate_new_leases' /usr/lib/one/ruby/onedb/fsck/network.rb:463:ineach’
/usr/lib/one/ruby/onedb/fsck/network.rb:463:in calculate_new_leases' /usr/lib/one/ruby/onedb/fsck/network.rb:383:inblock in check_ar_leases’
/usr/lib/one/ruby/onedb/fsck/network.rb:340:in each' /usr/lib/one/ruby/onedb/fsck/network.rb:340:incheck_ar_leases’
/usr/lib/one/ruby/onedb/fsck/network.rb:43:in block in check_network' /usr/lib/ruby/vendor_ruby/sequel/dataset/actions.rb:141:inblock in each’
/usr/lib/ruby/vendor_ruby/sequel/adapters/mysql2.rb:162:in block (2 levels) in fetch_rows' /usr/lib/ruby/vendor_ruby/sequel/adapters/mysql2.rb:162:ineach’
/usr/lib/ruby/vendor_ruby/sequel/adapters/mysql2.rb:162:in block in fetch_rows' /usr/lib/ruby/vendor_ruby/sequel/adapters/mysql2.rb:93:in_execute’
/usr/lib/ruby/vendor_ruby/sequel/adapters/shared/mysql_prepared_statements.rb:36:in block in execute' /usr/lib/ruby/vendor_ruby/sequel/database/connecting.rb:251:inblock in synchronize’
/usr/lib/ruby/vendor_ruby/sequel/connection_pool/threaded.rb:105:in hold' /usr/lib/ruby/vendor_ruby/sequel/database/connecting.rb:251:insynchronize’
/usr/lib/ruby/vendor_ruby/sequel/adapters/shared/mysql_prepared_statements.rb:36:in execute' /usr/lib/ruby/vendor_ruby/sequel/dataset/actions.rb:952:inexecute’
/usr/lib/ruby/vendor_ruby/sequel/adapters/mysql2.rb:197:in execute' /usr/lib/ruby/vendor_ruby/sequel/adapters/mysql2.rb:156:infetch_rows’
/usr/lib/ruby/vendor_ruby/sequel/dataset/actions.rb:141:in each' /usr/lib/one/ruby/onedb/fsck/network.rb:35:incheck_network’
/usr/lib/one/ruby/onedb/fsck.rb:454:in fsck' /usr/lib/one/ruby/onedb/onedb.rb:280:infsck’
/usr/bin/onedb:405:in block (2 levels) in <main>' /usr/lib/one/ruby/cli/command_parser.rb:457:inrun’
/usr/lib/one/ruby/cli/command_parser.rb:84:in initialize' /usr/bin/onedb:294:innew’
/usr/bin/onedb:294:in `’

Error running fsck version 5.6.0

The bug has been fixed here, thanks @superxor for reporting the bug!

1 Like